Use this topic to diagnose and correct problems that you experience with CMC. To know how to resolve or workaround your issue, browse through the following issues:
- HMC does not connect to Logstash over the 5044 port
- After upgrading HMC, status of Cloud Connector is either Inactive or Invalid Key
- Cloud Connector suddenly becomes inactive
- Secure connection failing in diagcloudconn
- Cloud Connector Start command is not working
- EP 2.0 app shows incomplete information warning on the EP 2.0 Inventory page
HMC does not connect to Logstash over the 5044 port
Symptom
The state of Cloud Connector in HMC is active, but the HMC status in the CMC portal is stale, that is, orange.
Probable root cause
The required firewall rules for Logstash connection were not set properly.
Environment
All HMC versions.
Resolution
Check the proxy or firewall settings to confirm whether the following actions are enabled:
- Allow NON-HTTPS outbound connection to <logstash ip address or FQDN> and port as "5044".
- Allow tunneling over the 5044 port and disable SSL interception.
- Disable the SSL Intercept for <logstash ip address> and port as "5044".
After upgrading HMC, the Cloud Connector state is either Inactive or Invalid Key
Symptoms
- After upgrading the HMCs to V10R3M1060/MF79618, the Cloud Connector state is active for 1 - 2 hours, and then after running the restart command from the command line, the Cloud Connector state changes to Inactive.
- The Cloud Connector state might also change to Invalid Key even though the key is being copy-pasted from the site or being retrieved from SSH.
Probable root cause
You allowed only one IP address for the Cloudant URL and the iam.cloud.ibm.com URL, whereas these URLs may resolve to different IP address and different times.
Environment
All HMC versions.
Resolution
Change the firewall rules from single IP address to FQDN.
Cloud Connector state suddenly becomes Inactive
Symptom
The Cloud Connector state in HMC was Active, but suddenly the state changes to Inactive state. The HMC status in the CMC portal is stale, that is, orange.
Probable root cause
The access to the Cloudant URL from Cloud Connector was blocked for more than 5 minutes by an outage in your network.
Environment
HMC versions earlier than 1061.
Resolution
- Fix your network outage.
- Upgrade to HMC 1061. This version has extended time for withstanding network outage for 24 hours.
Secure connection failing in diagcloudconn
Symptom
A secure connection fails message is displayed on diagcloudconn along with the URL that failed to connect.
Probable root cause
Either the Portal URL or Cloudant URL is not accessible from Cloud Connector. This inaccessibility might be due to either the network rules or the certificate chain not being added to HMC trust store.
Environment
HMC 1060 and later.
Resolution
Customer should check the network rules. 2.Customer should add the certificate chain of the URL in HMC trust store for which ever URL is failing.
Cloud Connector Start command is not working
Symptom
When you run the Start command in Cloud Connector, it ends immediately.
Probable root cause
Cloud Connector is already up and running.
Environment
All HMC versions.
Resolution
Try using the Restart command instead of the Start command.
EP 2.0 app shows incomplete information warning on the EP 2.0 Inventory page
Symptom
Core Usage and Memory Usage columns display -- on the EP2.0 Inventory page.
The following warning message is displayed: Incomplete information: metrics below reflect only systems reporting current usage (0/n systems).
Possible causes
- Cloud Connector is disconnected.
- HMC time is not synchronized with NTP.
Environment
All HMC versions.
Resolution
- Check each HMC’s Cloud Connector connection.
- Use diagcloudconn on each HMC to identify connection issues and reconnect Cloud Connector.
-
Check the NTP configuration on each HMC and reconfigure if required.
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